dle.in.ua » Хаки » Исправляем баг с аудио плеером

Исправляем баг с аудио плеером

Автор: Daniel от 13-02-2010, 13:48
Если ваш аудио плеер выглядит вот так...


Исправляем баг с аудио плеером


Решение смотрите в полной новости...
Рабочий вариант решения бага с аудио плеером

находим файл parse.class.php

        return "<!--dle_audio_begin:{$list}--><object classid=\"clsid:D27CDB6E-AE6D-11cf-96B8-444553540000\" codebase=\"http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0\" width=\"{$this->video_config['width']}\" height=\"30\" width=\"400\" id=\"Player-{$id_player}\">
                <param name=\"movie\" value=\"" . $config['http_home_url'] . "engine/classes/flashplayer/media_player.swf?MediaLink={$url}&defaultMedia=1&showPlayButton=false&playOnStart={$this->video_config['play']}{$color['backgroundBarColor']}{$color['btnsColor']}&outlineColor=0x666666{$color['outputBkgColor']}{$color['outputTxtColor']}{$color['loadingBarColor']}{$color['loadingBackgroundColor']}{$color['progressBarColor']}{$color['volumeBackgroundColor']}{$color['volumeStatusBarColor']}\" />
                <param name=\"allowFullScreen\" value=\"false\" />
                <param name=\"quality\" value=\"high\" />
                <param name=\"wmode\" value=\"transparent\" />
                <embed src=\"" . $config['http_home_url'] . "engine/classes/flashplayer/media_player.swf?MediaLink={$url}&defaultMedia=1&showPlayButton=false&playOnStart={$this->video_config['play']}{$color['backgroundBarColor']}{$color['btnsColor']}&outlineColor=0x666666{$color['outputBkgColor']}{$color['outputTxtColor']}{$color['loadingBarColor']}{$color['loadingBackgroundColor']}{$color['progressBarColor']}{$color['volumeBackgroundColor']}{$color['volumeStatusBarColor']}\" quality=\"high\" wmode=\"transparent\" allowFullScreen=\"false\" width=\"{$this->video_config['width']}\" height=\"30\" align=\"middle\" type=\"application/x-shockwave-flash\" pluginspage=\"http://www.macromedia.com/go/getflashplayer\"></embed>
                </object><!--dle_audio_end-->";


Меняем на:

        return "<!--dle_audio_begin:{$list}--><object classid=\"clsid:D27CDB6E-AE6D-11cf-96B8-444553540000\" codebase=\"http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0\" width=\"400\" height=\"30\" id=\"Player-{$id_player}\">
                <param name=\"movie\" value=\"" . $config['http_home_url'] . "engine/classes/flashplayer/media_player.swf?MediaLink={$url}&defaultMedia=1&showPlayButton=false&playOnStart={$this->video_config['play']}{$color['backgroundBarColor']}{$color['btnsColor']}&outlineColor=0x666666{$color['outputBkgColor']}{$color['outputTxtColor']}{$color['loadingBarColor']}{$color['loadingBackgroundColor']}{$color['progressBarColor']}{$color['volumeBackgroundColor']}{$color['volumeStatusBarColor']}\" />
                <param name=\"allowFullScreen\" value=\"false\" />
                <param name=\"quality\" value=\"high\" />
                <param name=\"wmode\" value=\"transparent\" />
                <embed src=\"" . $config['http_home_url'] . "engine/classes/flashplayer/media_player.swf?MediaLink={$url}&defaultMedia=1&showPlayButton=false&playOnStart={$this->video_config['play']}{$color['backgroundBarColor']}{$color['btnsColor']}&outlineColor=0x666666{$color['outputBkgColor']}{$color['outputTxtColor']}{$color['loadingBarColor']}{$color['loadingBackgroundColor']}{$color['progressBarColor']}{$color['volumeBackgroundColor']}{$color['volumeStatusBarColor']}\" quality=\"high\" wmode=\"transparent\" allowFullScreen=\"false\" width=\"400\" height=\"30\" align=\"middle\" type=\"application/x-shockwave-flash\" pluginspage=\"http://www.macromedia.com/go/getflashplayer\"></embed>
                </object><!--dle_audio_end-->";


Решение изначально не моё, я лишь поправил код до корректной его работы т.к. у самого была такая же проблема 8.3 версии.
  • Группа: Гости
  • Icq: --
  • Комментариев: 0
  • Публикаций: 0
  • Автор ты изобрёл Велосипед!
    • Finger
    • Регистрация: --
    • Репутация: (||)
    • 13 февраля 2010 17:42
    • 1
    ^
  • Группа: User
  • Icq: --
  • Комментариев: 156
  • Публикаций: 2
  • незнаю у меня и до этого норм ;)
    • Dimas-rap
    • Регистрация: 16.08.2008
    • Репутация: (0|0|0)
    • 13 февраля 2010 18:26
    • 2
    ^
  • Группа: User
  • Icq: --
  • Комментариев: 253
  • Публикаций: 9
  • юзайте jw
    • pav
    • Регистрация: 18.01.2009
    • Репутация: (0|0|0)
    • 13 февраля 2010 19:43
    • 3
    ^
  • Группа: Гости
  • Icq: --
  • Комментариев: 0
  • Публикаций: 0
  • а в чем там проблема?
    • gari
    • Регистрация: --
    • Репутация: (||)
    • 13 февраля 2010 20:05
    • 4
    ^
  • Группа: User
  • Icq: --
  • Комментариев: 8
  • Публикаций: 0
  • Спасибо!)) Помогла!

    --------------------
    • Burik
    • Регистрация: 12.06.2009
    • Репутация: (0|0|0)
    • 16 февраля 2010 00:50
    • 5
    ^
  • Группа: User
  • Icq: 408605082
  • Комментариев: 15
  • Публикаций: 1
  • /engine/classes
    • Andrik2392
    • Регистрация: 31.01.2010
    • Репутация: (0|0|0)
    • 16 марта 2010 23:05
    • 6
    ^
    Информация
    Посетители, находящиеся в группе Гости, не могут оставлять комментарии к данной публикации.